Xsens Motioncloud requirements

Below you can find the requirements to use Xsens motioncloud.

These requirements are valid per: 08/12/2020

Supported web browsers

The web application can run in any of the following web browsers that run on the specified operating systems:

  • Microsoft Edge (latest publicly available version) on Windows 10. This applies to both legacy Edge as well as the Microsoft Edge based on Chromium.
  • Google Chrome (latest publicly available version)
  • Apple Safari (latest publicly available version)

Internet Connection

 

Bandwidth requirements for the app depend on your scenario.

Most typical scenarios don't require a bandwidth that is more than 50 kilobytes per second (KBps). However, we recommend more bandwidth for faster uploads 

Be aware that load times will be slow on a 50KBps connection. 

To see what kind of connection you have, you can visit: 

www.speedtest.net 

Contact us

Please do not hesitate to contact us if you have any questions with regards to the Xsens motioncloud requirements.

Xsens Technologies B.V.
Pantheon 6a
7521 PR Enschede
+31 88 97367 00
info@xsens.com
Chamber of Commerce no. 50142224